Olstats doesn't upload logs...

Discuss OLStats here

Olstats doesn't upload logs...

Postby LemU on Sun Jun 19, 2005 6:51 am

Ok, I have installed Olstats... But it doens't upload log files??? It seems to be able to connect parses....

OLStats: ----------------------------------------
OLStats: OLStats Loading...
Warning: OLLocalGameStats DM-Rrajigar.OLLocalGameStats (Function OLStats.OLLocalGameStats.GetLogFilename:005A) Accessed None 'GameReplicationInfo'
Log: Opening user log ..\UserLogs\Stats_7777_2005_06_19_05_43_30.log
OLStats: OLStats 3.00 loaded!
OLStats: Author: OverloadUT
OLStats: Email: Overload@planetunreal.com
OLStats: Web: http://www.apartment167.com
OLStats: ----------------------------------------
Log: Resolving http://www.gaming-xperience.net...
ScriptLog: GameInfo::InitGame : bEnableStatLogging True
ScriptLog: bAutoNumBots: False
ScriptLog: UdpServerQuery(crt): Port 7787 successfully bound.
Log: Resolving master0.gamespy.com...
ScriptLog: MasterServerUplink: MasterServerGameStats not found - stats uploading disabled.
Log: Defaulting to false
Log: Defaulting to false
Log: Resolving ut2004master1.epicgames.com...
ScriptLog: Webserver is not enabled. Set bEnabled to True in Advanced Options.
ScriptLog: ****************************************
ScriptLog: OLStats Special Mutator Compatability
ScriptLog: UT2004 RPG detected
ScriptLog: Spawning special UT2004RPG Stats handler
ScriptLog: Spawn Successful!
ScriptLog: ****************************************
Log: Spawning new actor for Viewport WindowsViewport
ScriptLog: New Player LemU id=32af618f3ba1ef8264f8deefed08553c
Log: MasterServerUplink: Resolved ut2004master1.epicgames.com as 207.135.145.6.
Log: Resolved http://www.gaming-xperience.net (xxx.xxx.xx.xx)
Log: Resolved master0.gamespy.com (207.38.11.34)
ScriptLog: UdpGameSpyUplink: Master Server is master0.gamespy.com:27900
ScriptLog: UdpGameSpyUplink: Port 7788 successfully bound.
Log: Precaching: DM-Rrajigar.LevelInfo0
Log: Static mesh batches: 5802112 vertex bytes, 611028 index bytes
Log: Allocating 16384 byte dynamic index buffer.
Log: Finished precaching geometry in 3.292 seconds
Log: Finished precaching textures in 1.652 seconds
Log: MasterServerUplink: Connection to ut2004master1.epicgames.com established.
OLStats: ----------------------------------------
OLStats: OLStats Remote Parser Operation Complete
OLStats: Parser Result:
OLStats: No log file to process.
OLStats:
OLStats: ----------------------------------------
Log: Approval APPROVED
Log: Master server requests heartbeat 0 with code 236
Log: Master server requests heartbeat 1 with code 236
Log: Master server requests heartbeat 2 with code 236
Log: Master server assigned our MatchID: 0
ScriptLog: START MATCH



What this means???

Log: Resolved http://www.gaming-xperience.net (194.100.84.79)
Error: HttpSock DM-Rrajigar.HttpSock (Function LibHTTP2.HttpSock.Closed:0107) Accessed array 'RequestHistory' out of bounds (1/1)
Error: HttpSock DM-Rrajigar.HttpSock (Function LibHTTP2.HttpSock.Closed:0118) Accessed array 'RequestHistory' out of bounds (1/1)

I would be very happy for help :)
LemU
 

Postby LemU on Sun Jun 19, 2005 10:56 am

Btw. If I upload log files with ftp and then run parser it works....
So ploblem can't be parser... Hmmm... I'm going to try that I'll put log files to my server and see if Olstats can parse it....
LemU
 

Postby LemU on Sun Jun 19, 2005 11:18 am

Ok, parser works.... Only problem is that why my logs files doesn't upload to server?
Should there be something text about that in ut2004.log???


Please Help!
LemU
 

stats not uploading

Postby blindrain on Tue Jun 28, 2005 7:54 pm

I have the same problem with the stats not uploading to my site
[url]http://whitacrecomputers.com/UTStats/
[/url]
is the location of my UTStats
blindrain
 

Uploading

Postby Shotaro on Mon Aug 29, 2005 2:53 pm

I have same problem with uploading.. Please somebody try and help me, it's pissing me off.


Code: Select all
----------------------------------------
OLStats Stat Uploader Operation Complete
  Return code: 998
  ERROR: Unknown error.
  Check to make sure you have the correct
  URL specified in OLStats.ini
  Also try manually entering the URL in a browser
  and check for errors.
----------------------------------------


And yes it is the right URL.[/code]
Shotaro
 

Postby VorteX on Tue Oct 25, 2005 6:04 am

I use UTStatsdb version 3 RC1 and OLStats 3.01

I have had the same problem with uploading and used to get this error:
----------------------------------------
OLStats Stat Uploader Operation Complete
Return code: 998
ERROR: Unknown error.
Check to make sure you have the correct
URL specified in OLStats.ini
Also try manually entering the URL in a browser
and check for errors.
----------------------------------------

Then i got the modified version of the OLSendlog for UTStatsDB version 3 RC1 and now i get this error:

OLStats: ----------------------------------------
OLStats: OLStats Stat Uploader Operation Complete
OLStats: Return code: 2
OLStats: ERROR: Incorrect password.
OLStats: Check your UploadPass in OLStats.ini
OLStats: ----------------------------------------

All my passwords and settings are correct and I've tried useing different settings and passwords, but I still can't get OLStats to upload.

Heres the link for the modified OLSendlog for UTStatsdb version 3:
http://prdownloads.sourceforge.net/ut20 ... r?download

If anyone has a solution or fix im all ears :wink:
VorteX
 

Postby Cobalt on Sun Oct 30, 2005 11:25 am

i have the same problem Error 998 until i try the new OLSendog.php file then I run in to the Inorrect Password error. Any thoughts?
Cobalt
 

Postby Denis on Fri Nov 25, 2005 4:44 am

Hello. thank you for a great program.

I have a problem, with UTststsDB v.3.00RC1 and
Olstats v.3.01. I set up on my win 2003 platform the apache2, php 5.6.8, mysql 5 (tryed version 4, with same result) and configured all settings as your instruction says.
utstatsdb created all needed tables in the utstats db database, says "ok". I can lunch my browser and type http://localhost/utstats to see a utstats web page.
i'v also set up an olstats and it makes logs. However, it doesn't want to load it to your program (the whole setup running on my standalone PC, apache using a standart port 80) if i place log files into folder, i specified in utstatsdb's settings, it parses it without any troubles.

here is the part of log from my ut server

Log: Log file open, 11/24/05 23:43:15
Init: Name subsystem initialized
Init: Detected: Microsoft Windows XP 5.2 (Build: 3790)
Init: Version: 3339 (128.29)
Init: Compiled: Nov 11 2004 10:49:37
Init: Command line: DM-HyperBlast2.ut2?game=XGame.xDeathMatch?GameStats=True ini=UT2004.ini log=server.log
Init: Character set: Unicode
Init: Base directory: D:\UT2004_SERVER\System\
Init: Ini:UT2004.ini UserIni:User.ini
Init: Build label: Build UT2004_Build_[2004-11-11_10.48]
Init: Object subsystem initialized
Log: Executing Class Engine.ServerCommandlet
Log: Browse: DM-HyperBlast2.ut2?Name=Player?Class=Engine.Pawn?Character=Jakob?team=255?game=XGame.xDeathMatch?GameStats=True
Log: Collecting garbage
Log: Purging garbage
Log: Garbage: objects: 29695->29692; refs: 441053
Log: Game class is 'xDeathMatch'
Log: Bringing Level DM-HyperBlast2.myLevel up for play (25) appSeconds: 19.927000...
Log: (Karma): Autodetecting CPU for SSE
Log: (Karma): Using SSE Optimizations
ScriptLog: Loading Admins & Groups
ScriptLog: Kick and Ban Privileges Loaded
ScriptLog: Maps & Game Privileges Loaded
ScriptLog: Admins & Groups Management Loaded
ScriptLog: Extra Privileges Loaded
ScriptLog: GameInfo::InitGame : bEnableStatLogging True
OLStats: ----------------------------------------
OLStats: OLStats Loading...
Log: Opening user log ..\UserLogs\Stats_7777_2005_11_24_23_43_29.log
OLStats: OLStats 3.00 loaded!
OLStats: Author: OverloadUT
OLStats: Email: Overload@planetunreal.com
OLStats: Web: http://www.apartment167.com
OLStats: ----------------------------------------
Log: Resolving localhost...
ScriptLog: UdpServerQuery(crt): Port 7787 successfully bound.
... skipping a bit ...
OLStats: ----------------------------------------
OLStats: OLStats Remote Parser Operation Complete
OLStats: Parser Result:
OLStats: No log file to process.
OLStats:
OLStats: ----------------------------------------
.. skipping some more .....
Log: Resolving localhost...
Warning: xDeathMatch DM-HyperBlast2.xDeathMatch (Function Engine.GameInfo.EndLogging:0027) Accessed None 'GameStats'
Log: Resolved localhost (127.0.0.1)
OLStats: ----------------------------------------
OLStats: OLStats Stat Uploader Operation Complete
OLStats: Return code: 8
OLStats: ERROR: Unknown error.
OLStats: Check to make sure you have the correct
OLStats: URL specified in OLStats.ini
OLStats: Also try manually entering the URL in a browser
OLStats: and check for errors.
OLStats: ----------------------------------------


***end of log****

i double checked the olstats.ini to make sure, all paths are correct.
bouth paths looks like
to olsendlog.php (version 1.3) :
http://localhost/utstats/olsendlog.php
(i put this script there, is it ok?)
and to logs.php:
http://localhost/utstats/logs.php

i checked all passwords too. so i am sure i set all thouse right.

Please, help me to get all up and running.
Cheers!

EDIT:
I have solved my problem. The thing is, that i had to set up a FTP server on the UT server side and configure it, so UTSTATSDB can log onto it and get all logs. After that i had configured FTP settings in UtstatsDB admin page and voila! - now all working !!! :D
Denis
N00b
N00b
 
Posts: 1
Joined: Thu Nov 24, 2005 5:00 pm

Postby Guest on Wed Dec 28, 2005 9:18 am

Cobalt wrote:i have the same problem Error 998 until i try the new OLSendog.php file then I run in to the Inorrect Password error. Any thoughts?


Same problem here Cobalt. I opened OLSendlog.php for UTStatsdb version 3 and found some errors. I modified some lines of code and it works fine now.

Open your OLSendlog.php and modified the next lines:

function loadconfig()
{
global $dbpre, $magicrt, $config, $conflogs;

$link = sql_connect();
$result = sql_querynb($link, "SELECT value FROM {$dbpre}config WHERE conf='UpdatePass' LIMIT 1");
if ($result && sql_num_rows($result)) {
$row = sql_fetch_row($result);
$UpdatePass = $magicrt ? stripslashes($row[1]) : $row[1];
sql_free_result($result);
}
else {
send_result("7");
exit;
}
...
}

change to:
=======

function loadconfig()
{
global $dbpre, $magicrt, $config, $conflogs, $UpdatePass, $logpath;

$link = sql_connect();
$result = sql_querynb($link, "SELECT value FROM {$dbpre}config WHERE conf='UpdatePass' LIMIT 1");
if ($result && sql_num_rows($result)) {
$row = sql_fetch_row($result);
$UpdatePass = $magicrt ? stripslashes($row[0]) : $row[0];
sql_free_result($result);
}
else {
send_result("7");
exit;
}
...
}
Guest
 

Postby Overload on Thu May 18, 2006 1:30 pm

I believe the creator of UTStatsDB actually included a new version of OLSendLog.php in the newer versions of UTStatsDB. I haven't looked at it myself, but I can only assume it's a better version, as his php skills are far superior than mine. :)
Sig Under Consutrction
User avatar
Overload
Site Admin
Site Admin
 
Posts: 1300
Joined: Tue May 06, 2003 5:00 pm
Location: Novato, California


Return to OLStats

Who is online

Users browsing this forum: No registered users and 2 guests

cron